SciKits

Quick search

scikit-sparse

version 0.4.2

Scikits sparse matrix package

Download: https://pypi.python.org/pypi/scikit-sparse
Homepage: https://github.com/scikit-sparse/scikit-sparse/
PyPI: http://pypi.python.org/pypi/scikit-sparse
People: Antony Lee

Description

Sparse matrix tools.

This is a home for sparse matrix code in Python that plays well with scipy.sparse, but that is somehow unsuitable for inclusion in scipy proper. Usually this will be because it is released under the GPL.

So far we have a wrapper for the CHOLMOD library for sparse Cholesky decomposition. Further contributions are welcome!

Installation

PyPI

You can download the latest distribution from PyPI here: http://pypi.python.org/pypi/scikit-sparse

Using pip

You can install scikit-sparse for yourself from the terminal by running:

pip install --user scikit-sparse

If you want to install it for all users on your machine, do:

pip install scikit-sparse
On Linux, do sudo pip install scikit-sparse.

If you don't yet have the pip tool, you can get it following these instructions.

This package was discovered in PyPI.